새 소식

출처: http://la-nube.tistory.com/316 [la Nube's Lab. | 라 누베 연구소]



<이 내용은 2018년 1월 10일 22시 00분 기준으로 작성되었습니다.>


다음의 내용은 우분투에 기반한 리눅스민트, 하모니카 등에도 당연히(?) 적용됩니다.

여기에서 말하는 우분투는 다른 모든 우분투 공식 및 비공식 변형판을 포함합니다. 예를 들어, 주분투, 루분투, 쿠분투, 우분투마테, 우분투벗지, 엘리멘터리OS, 페퍼민트OS, 리눅스라이트, 조린OS 등을 모두 포함합니다.


우분투 16.04 LTS의 HWE(Hardware Enablement; 하드웨어 지원 강화) 커널은

우분투 17.04에서 3개월의 테스트를 거친 커널 4.10을 6개월 동안 사용해왔으나,

우분투 17.10과 그 커널 4.13이 출시일로부터 3개월이 다 되어 감에 따라

커널 4.10에서 커널 4.13으로 변경되어 발표되었습니다.


HWE 커널에 해당하는 패키지인 linux-hwe가 4.10.0-42.46~16.04.1 에서

4.13.0-26.29~16.04.2 으로 변경되어 지금으로부터 3시간 전에 발표되었으며,

우분투 16.04.4 라는 다음 포인트 릴리즈의 기본 커널로 탑재되어 공개될 예정입니다.


996E83335A5611FB10F848


다음은 현재 발표된 linux-hwe 4.13.0-26.29~16.04.2 에 대한 내용입니다.

패치 내용에 나오는 CVE-2017-5754는 인텔 CPU 등의 멜트다운 취약점을 의미합니다.

linux-hwe (4.13.0-26.29~16.04.2) xenial; urgency=low

  * linux-hwe: 4.13.0-26.29~16.04.2 -proposed tracker (LP: #1742177)

  * linux: 4.13.0-25.29 -proposed tracker (LP: #1741955)

  * CVE-2017-5754

    - Revert "UBUNTU: [Config] updateconfigs to enable PTI"

    - [Config] Enable PTI with UNWINDER_FRAME_POINTER


--


HWE 커널이 커널 4.13으로 올라감에 따라, 기존의 커널 4.10은 더 이상 지원되지 않습니다.

따라서, 우분투, 리눅스민트, 하모니카 등 다음에 해당하는 경우에는 반드시 업데이트를 하기 바랍니다.


사용 중인 커널을 확인하는 방법은 터미널에서 uname -a 라고 입력하면 됩니다.


우분투 16.04 LTS의 HWE 커널 (커널 4.10, 커널 4.8) 사용자

 - 터미널에서

   $ sudo apt-get update && sudo apt-get dist-upgrade -y && sudo apt-get autoremove --purge -y && sudo apt-get autoclean

 - 재부팅

   $ sudo reboot


리눅스민트 18.x의 HWE 커널 (커널 4.10, 커널 4.8) 사용자

 - 업데이트 매니저 → 메뉴 중 보기(V) → 리눅스 커널 에서 "커널 4.13" 중 커널 4.13.0-26 이상 설치

 - 재부팅 : 시작 메뉴 - 종료 - 다시 시작(R)


하모니카 커뮤니티 배포판 MoorDev 1.0 (18.3 Sylvia 기반) 사용자

 - 업데이트 매니저 → 메뉴 중 보기(V) → 리눅스 커널 에서 "커널 4.13" 중 커널 4.13.0-26 이상 설치

 - 재부팅 : 시작 메뉴 - 종료 - 다시 시작(R)


<참고>

https://launchpad.net/ubuntu/+source/linux-hwe/4.13.0-26.29~16.04.2



출처: http://la-nube.tistory.com/316 [la Nube's Lab. | 라 누베 연구소]

나의 소셜 정보
powered by SocialXE